v0.10.4 - October 03, 2017

  • FEATURE: Try both /usr/local/apache/htdocs and /var/www/html for hostcert validation, if they exist, in addition to any configured path.
  • FIX: Plugin will restore Let’s Encrypt cabundle which may be deleted incorrectly by cPanel in some environments (cPanel case 8829413).
  • FIX: Fix error spam issue with API tokens on cPanel servers too old to support API-token-based authentication.
  • FIX: Avoids graceful Apache restarts on servers that aren’t using deferred_restarts.
  • FIX: Handle fetch_ssl_vhost API being changed in upcoming cPanel version 68.

These release notes also include the changes that occured in 0.10.3, which was released a month ago:

  • FIX: Try to use API token before resorting to access hash
  • MISC: ACME poll timeout increased to 90s to give better error information when nameservers not supporting CAA are timing out.